You are not logged in.

Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

41

Wednesday, January 4th 2017, 5:45pm

Sowas habe ich vermutet. Ich schau mir den Code nochmal genauer an ;)
Du bist einfach der Beste :-) Ich danke dir schon mal im Vorraus ;-)

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

42

Wednesday, January 4th 2017, 8:39pm

Bitte, kein Problem ^^
Fehler erkannt, Fehler gebannt :D

Zeile 71 bitte das zweite = Zeichen entfernen, dann sollte es gehen.
Soll dann so aussehen

Source code

1
 fanOut = false;



Gruß Bert


Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

43

Thursday, January 5th 2017, 8:11pm

Bitte, kein Problem ^^
Fehler erkannt, Fehler gebannt :D

Zeile 71 bitte das zweite = Zeichen entfernen, dann sollte es gehen.
Soll dann so aussehen

Source code

1
 fanOut = false;



Gruß Bert
Hallo Bert,

Ich danke dir für deine rasche Antwort :-)

Ich habe den Fehler behoben, dieser war bei mir auf Zeile 70. Leider hat es nicht geklappt und der Lüfter läuft nach wie vor nicht. Ich habe ebenfalls in Zeile 77 den Befehl mit zwei Gleichzeichen gefunden if (fanOut == false). Wenn ich dieses herausnehme und auf mein Arduino spiele funktioniert es auch nicht. Interessant ist es jedoch, dass wenn ich den Quellcode uploade der Lüfter kurz auf 100 %. Ich habe den Stand vor dem seriellen monitoring benutzt. Ist dies so falsch?

Kannst du evtl. deinen nochmals hochladen, dass ich auch die richtige Version benutze ? :-)

Ich danke dir schonmal im Vorraus und wünsche dir einen schönen Restabend.

Viele Grüsse
Lukas

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

44

Thursday, January 5th 2017, 8:47pm

Hm, ich finde keinen Fehler mehr. Zeile 77 stimmt schon so.
Versuchs nochmal mit meinem Code.
Scynd has attached the following file:


Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

45

Thursday, January 5th 2017, 9:47pm

komisch, ich hab jetzt mal den Test gemacht mit deinem. Leider hat der auch nicht funktioniert. Hab auch den PWM im Mapping noch ein wenig hochgestellt und sämtliche Temperatur von 18°C bis 33°C durchgespielt.

Serielles Monitoring schaut soweit gut aus. Ab 23°C bekomme ich fanout: 0. und darunter fanout: 1. Wie es sein sollte.

Kennst du eine Möglichkeit, dass ich den PWM Wert welcher an den Lüfter gesendet wird wie im seriellen monitoring auszulesen ?

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

46

Thursday, January 5th 2017, 11:10pm

Oh man...
Fehler gefunden. Ich hatte keine ausgabe an den fanPin eingebaut :whistling:
Scynd has attached the following file:


Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

47

Saturday, January 7th 2017, 9:00pm

Oh man...
Fehler gefunden. Ich hatte keine ausgabe an den fanPin eingebaut :whistling:
Hallo Bert,

Du hast es geschafft der Lüfter dreht :thumbsup:.

Leider funktioniert es noch nicht zu 100%. Der Lüfter beginnt je nach PWM Einstellung bei 26-28°C zu drehen mit ca. 75% Leistung und steigert sich dann bis auf 33°C bei welchem er abstellt. In den Konstanten ist jedoch 22°C als Startwert definiert welcher auch im seriellen Monitoring so anzeigt. Ein Anpassen der Mindestempertatur bringt auch kein wirkliches Ergebnis wie auch den Mindestwert für den PWM (zwischen 1 und 100 durchprobiert).

Ich schätze es hat noch einen kleinen Bug in der Steinhard Formel. Ich werd die Morgen mal mit der aus deinem Tutorial vergleichen. Was mit noch durch den Kopf geht ist das der Fehler evtl. durch meine Verlängerung vom NTC kommt. Wäre dies möglich ?

Achja alle aufgelisteten Temperaturen hab ich von dem Display abgelesen.

Ich wünsche dir einen schönen und entspannten Samstag Abend :) .

Viele Grüsse
Lukas

Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

48

Monday, January 9th 2017, 3:52pm

Hallo Bert,

Ich wollt kurz ein Update geben. Leider hab ich bisher noch keine Erkenntnis gefunden wieso die Lüfterdrehzahl nicht mit der Temperatur übereinstimmt.

Hast du eine Idee wie ich den PWM wie im seriellen Monitoring auslesen könnte ?

Die Steinhardformel stimmt 1 zu 1 mit die aus deinem Tutorial überein

Beste Grüsse
Lukas

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

49

Monday, January 9th 2017, 8:48pm

Ich habe heute leider keine Zeit nochmal drüber zu schauen, aber morgen in der Arbeit finden sich sicher ein paar Minuten :D


Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

50

Thursday, January 12th 2017, 12:19pm

Also ich glaube nicht das es an der Temperaturerfassung liegt. Du siehst ja die Temperatur auf dem Display und mit dieser arbeitet auch die Geschwindigkeitssteuerung.
Was ich komisch finde, ist dass er bei 33° aus geht ?(
Ich habe gerade noch etwas entdeckt. Der PWM Pin am Arduino läuft ja noch mit 490Hz :wacko: . Laut Intes Spezifikation für PWM Lüfter sollen das aber 25kHz sein. Das geht beim Arduino leider nicht, aber 31,3kHz. Ich habe die nötige Zeile Code unter Setup eingefügt. Versuch es jetzt nochmal bitte.

Wenn dich das näher interessiert, hier ein Tutorial von mir :thumbsup:


Gruß Bert
Scynd has attached the following file:


Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

51

Thursday, January 12th 2017, 9:30pm

Also ich glaube nicht das es an der Temperaturerfassung liegt. Du siehst ja die Temperatur auf dem Display und mit dieser arbeitet auch die Geschwindigkeitssteuerung.
Was ich komisch finde, ist dass er bei 33° aus geht ?(
Ich habe gerade noch etwas entdeckt. Der PWM Pin am Arduino läuft ja noch mit 490Hz :wacko: . Laut Intes Spezifikation für PWM Lüfter sollen das aber 25kHz sein. Das geht beim Arduino leider nicht, aber 31,3kHz. Ich habe die nötige Zeile Code unter Setup eingefügt. Versuch es jetzt nochmal bitte.

Wenn dich das näher interessiert, hier ein Tutorial von mir :thumbsup:


Gruß Bert
Hey Bert,

Du bist ein GENIE es halt geklappt :thumbsup: mega geil hehe auf dies wäre ich jetzt echt nie gekommen. Da bin ich schon froh solche super Unterstützung von dir bekommen zu haben :-) In diesem Sinne nochmals herzlichsten Dank!

Ich möchte mich auf jedenfall noch mehr in die Arduino Steuerung einlesen, da ich noch einiges geplannt habe was ich noch basteln möchte. Wird also nicht das letzte Mal das ich hier etwas vorstelle ;-)

Der Lüfter dreht jetzt bis 30°C und schaltet dann ab, das macht aber nichts da ich sowieso noch ein wenig spielen möchte mit verschiedenen Einstellungen. Ich hoffe, dass ich am Wochenende alles anschliessen und noch ein paar schöne Fotos schiessen kann. Werd diese dann hier bestimmt hochladen.

In diesem Sinne wünsche ich dir noch einen schönen Abend

Viele Grüsse
Lukas :)

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

52

Friday, January 13th 2017, 7:41am

Suuuuuper, das freut mich ^^
Ich habe noch eine kleine Abfrage eingebaut, damit der Lüfter ab 30° mit voller Geschwindigkeit weiter läuft. Du kannst ja nochmal mit dem minimalen PWM Wert in der "map" Funktion rumspielen, ob der Lüfter schon bei einem kleineren Wert anläuft. Das musst du halt auf deine Bedürfnisse anpassen ;)
Ausserdem habe ich die Ausgabe am Seriellen Monitor wieder rausgenommen, da das jetzt ja nicht mehr notwendig ist.

Ich bin schon auf die fertigen Bilder gespannt und natürlich auf folgende Projekte. Wenn man erst einmal die Möglichkeiten vom Arduino entdeckt hat, will man den überall einbauen :rofl:

Gruß Bert
Scynd has attached the following file:


Hobbybiologe

Neu Hier!

  • "Hobbybiologe" started this thread

Posts: 25

Date of registration: Nov 1st 2016

  • Send private message

53

Monday, January 23rd 2017, 12:35pm

Hallo Bert :-)

Tut mir leid für die verspätete Rückmeldung. Ich war leider in letzter Zeit mit einigen anderen Sachen beschäftigt und bin noch nicht dazu gekommen ein paar schöne Bilder zu schiessen da bei mir noch ein wenig Chaos herscht :D

Was mir noch aufgefallen ist, dass der Lüfter sehr "impulsiv" läuft bedeutet das er schnell hochdreht und dann wieder runter in wenigen Sekunden. Hast du dazu ne Idee was ich tun könnte ? Bin mir etwas unsicher ob ich den oberen PWM Wert runterreglen soll da ich sowieso einen ziemlich hoch dimensionierten Lüfter habe. Für die PWM untergrenze bin ich mittlerweile bei 60. Ich denke aber da würde sich noch etwas machen lassen sodass ich noch weiter runter komme evtl. 50.

Ebenfalls habe ich mir überlegt die Abfragen zu erhöhen, dies sollte doch ebenfalls einen gleichmässigeren Lauf ermöglichen oder wie siehst du das ?

Beste Grüsse

Lukas :-)

Scynd

1. Platz Enermax Casecon Contest

Posts: 915

Date of registration: Mar 12th 2012

Location: München

Occupation: Maschinenbautechniker

Thanks: 74

  • Send private message

54

Monday, January 23rd 2017, 2:55pm

Hi,
also ich würde als erstes den maximalen PWM Wert runtersetzen, wenn du nicht die volle Geschwindigkeit brauchst. Dann wird auch die Schrittweite pro Grad des PWM Wertes kleiner und wirkt nicht so sprunghaft.
Also 255(ganzer PWM Bereich) - 60 (minimaler PWM) = 195
195 / 8 (min bis max Temperatur) = ~24
Also machst du mit jedem mal, wenn die Temperatur sich ändert einen Sprumg von 24 beim PWM Wert. Wenn du als max PWM jetzt z.B. 160 nimmst, sind es nur noch ~13. Das sollte schon besser aussehen.
Wenn das noch nicht reicht, kann man auch noch eine Stufenweise Anpassung der Geschwindigkeit vornehmen. Aber das bedeutet wieder Arbeit :P

Gruß Bert